go back to a10 because build keeps failing for stupid reasons that are making me angry
This commit is contained in:
parent
d2257f2130
commit
10caa1bbc2
7 changed files with 143 additions and 8882 deletions
24
0001-Add-Minimal-repo-support.patch
Normal file
24
0001-Add-Minimal-repo-support.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
From 2b5791f0ed5a4b6886b49eeefeed66511e7218ce Mon Sep 17 00:00:00 2001
|
||||
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||
Date: Fri, 9 Aug 2024 16:50:16 +0000
|
||||
Subject: [PATCH 1/3] Add Minimal repo support
|
||||
|
||||
---
|
||||
pyanaconda/core/constants.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/pyanaconda/core/constants.py b/pyanaconda/core/constants.py
|
||||
index 5232e6d..8e87274 100644
|
||||
--- a/pyanaconda/core/constants.py
|
||||
+++ b/pyanaconda/core/constants.py
|
||||
@@ -58,6 +58,7 @@ DEFAULT_REPOS = [
|
||||
"BaseOS", # Used by RHEL
|
||||
"baseos", # Used by CentOS Stream
|
||||
"eln-baseos", # Used by Fedora ELN
|
||||
+ "Minimal", # Used by AlmaLinux
|
||||
]
|
||||
|
||||
DBUS_ANACONDA_SESSION_ADDRESS = "DBUS_ANACONDA_SESSION_BUS_ADDRESS"
|
||||
--
|
||||
2.43.5
|
||||
|
|
@ -1,31 +0,0 @@
|
|||
From d1424ea9ffa5d51d1cfa004b0861e345c4300902 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Wed, 6 Mar 2024 17:26:45 -0800
|
||||
Subject: [PATCH] bootupd: call bootupctl with --update-firmware
|
||||
|
||||
This is required to write an entry to the EFI boot manager,
|
||||
which we ought to do (anaconda does it when installing the
|
||||
bootloader itself). Without this, boot of the installed system
|
||||
will only work if it's configured to try and boot from the
|
||||
hard disk using the fallback path.
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
.../modules/payloads/payload/rpm_ostree/installation.py | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/pyanaconda/modules/payloads/payload/rpm_ostree/installation.py b/pyanaconda/modules/payloads/payload/rpm_ostree/installation.py
|
||||
index 0ac8583b78..f5ea666cf2 100644
|
||||
--- a/pyanaconda/modules/payloads/payload/rpm_ostree/installation.py
|
||||
+++ b/pyanaconda/modules/payloads/payload/rpm_ostree/installation.py
|
||||
@@ -520,6 +520,7 @@ class ConfigureBootloader(Task):
|
||||
"install",
|
||||
"--auto",
|
||||
"--write-uuid",
|
||||
+ "--update-firmware",
|
||||
"--device",
|
||||
dev_data.path,
|
||||
"/",
|
||||
--
|
||||
2.44.0
|
||||
|
25
0002-Change-anaconda-background-color.patch
Normal file
25
0002-Change-anaconda-background-color.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 7d0eaa2ebb521e327b98171689e4731a7db5d503 Mon Sep 17 00:00:00 2001
|
||||
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||
Date: Fri, 9 Aug 2024 16:59:05 +0000
|
||||
Subject: [PATCH 2/3] Change anaconda background color
|
||||
|
||||
---
|
||||
data/anaconda-gtk.css | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/data/anaconda-gtk.css b/data/anaconda-gtk.css
|
||||
index f83cf15..e5d859c 100644
|
||||
--- a/data/anaconda-gtk.css
|
||||
+++ b/data/anaconda-gtk.css
|
||||
@@ -95,7 +95,7 @@ infobar.error box {
|
||||
* to be overridden by a stylesheet in product.img.
|
||||
*/
|
||||
|
||||
-@define-color anaconda_bg_color #2f4265;
|
||||
+@define-color anaconda_bg_color #2f4265;
|
||||
|
||||
.logo-sidebar {
|
||||
background-color: @anaconda_bg_color;
|
||||
--
|
||||
2.43.5
|
||||
|
55
0003-Remove-visible-Fedora-references.patch
Normal file
55
0003-Remove-visible-Fedora-references.patch
Normal file
|
@ -0,0 +1,55 @@
|
|||
From 36a77712950b1462573ade28c1bd6f175a201174 Mon Sep 17 00:00:00 2001
|
||||
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||
Date: Fri, 9 Aug 2024 17:03:55 +0000
|
||||
Subject: [PATCH 3/3] Remove visible Fedora references
|
||||
|
||||
---
|
||||
data/liveinst/gnome/fedora-welcome.js | 6 +++---
|
||||
.../liveinst/gnome/org.fedoraproject.welcome-screen.desktop | 2 +-
|
||||
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/data/liveinst/gnome/fedora-welcome.js b/data/liveinst/gnome/fedora-welcome.js
|
||||
index fc42e5d..ce60209 100755
|
||||
--- a/data/liveinst/gnome/fedora-welcome.js
|
||||
+++ b/data/liveinst/gnome/fedora-welcome.js
|
||||
@@ -46,7 +46,7 @@ class WelcomeWindow extends Adw.ApplicationWindow {
|
||||
}
|
||||
|
||||
constructor(application) {
|
||||
- const title = _('Welcome to Fedora!');
|
||||
+ const title = _('Welcome to AlmaLinux!');
|
||||
super({
|
||||
application,
|
||||
title,
|
||||
@@ -58,7 +58,7 @@ class WelcomeWindow extends Adw.ApplicationWindow {
|
||||
const statusPage = new Adw.StatusPage({
|
||||
title,
|
||||
iconName: 'fedora-logo-icon',
|
||||
- description: _('This live media can be used to install Fedora or as a temporary system. Installation can be started at any time using the install icon in Activities.'),
|
||||
+ description: _('This live media can be used to install AlmaLinux or as a temporary system. Installation can be started at any time using the install icon in Activities.'),
|
||||
});
|
||||
this.content.set_child(statusPage);
|
||||
|
||||
@@ -71,7 +71,7 @@ class WelcomeWindow extends Adw.ApplicationWindow {
|
||||
statusPage.set_child(buttonBox);
|
||||
|
||||
const installButton = new Gtk.Button({
|
||||
- label: _('Install Fedora…'),
|
||||
+ label: _('Install AlmaLinux…'),
|
||||
actionName: 'window.install-fedora',
|
||||
});
|
||||
installButton.add_css_class('pill');
|
||||
diff --git a/data/liveinst/gnome/org.fedoraproject.welcome-screen.desktop b/data/liveinst/gnome/org.fedoraproject.welcome-screen.desktop
|
||||
index c3551b1..8c9065b 100644
|
||||
--- a/data/liveinst/gnome/org.fedoraproject.welcome-screen.desktop
|
||||
+++ b/data/liveinst/gnome/org.fedoraproject.welcome-screen.desktop
|
||||
@@ -1,5 +1,5 @@
|
||||
[Desktop Entry]
|
||||
-Name=Welcome to Fedora
|
||||
+Name=Welcome to AlmaLinux
|
||||
Icon=fedora-logo-icon
|
||||
Exec=/usr/share/anaconda/gnome/fedora-welcome
|
||||
Terminal=false
|
||||
--
|
||||
2.43.5
|
||||
|
BIN
anaconda-40.22.3.13.tar.bz2
Normal file
BIN
anaconda-40.22.3.13.tar.bz2
Normal file
Binary file not shown.
Binary file not shown.
8890
anaconda.spec
8890
anaconda.spec
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue